Board index Windows

Moderator: chandranjoy

Windows 7 Sidebar doesn't run at start up, gadgets messed up

Postby chandranjoy » Sat Jul 07, 2012 12:27 pm

Windows 7 Sidebar doesn't run at start up OR Gadgets are messed up?

First, please check if the UAC is turned off. If so, please turn back on and check the issue.

After that, please run MSCONFIG to check if the sidebar.exe entry is added under Startup tab and go to check if the sidebar.exe entry is added under
Code: Select all
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]


If it does not work, please copy ATL.DLL from to C:\Windows\System32 to C:\Program Files\Windows Sidebar folder and run the following commands with elevated privilege:
Code: Select all
Run -> CMD
CD\
CD "C:\Program Files\Windows Sidebar"
REGSVR32 ATL.DLL
REGSVR32 SBDROP.DLL
REGSVR32 WLSRVC.DLL


If the issue persists, you can try the following steps to reset the Sidebar. The following steps will remove all downloaded gadgets.

Show Hidden File
Code: Select all
1. Click Start and click Control Panel.
2. Choose Folder Options.
3. Click View tab, choose Show hidden files and folders and uncheck Hide Protected Operating System Files and Folders box, click Apply and click OK.


Delete Sidebar files:
Code: Select all
1. Click Start -> Computer
2. Go to C:\Users\<user name>\AppData\Local\Microsoft\Windows Sidebar (where <user name> is your current user account name).
3. Open Settings.ini, press CTRL+A (select all) and press delete. The file is now empty. Save the file.
4. Browse into the Gadgets directory.
5. Select CTRL+A (select all) and delete them.


After that, please test your issue again.

I also would like to suggest you create a new user account (http://windows.microsoft.com/en-US/Windows7/Create-a-user-account) to test the issue.

Reference:
http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4b423cc2-1d79-477f-ba8a-dc5f4437d356/
chandranjoy
Site Admin
 
Posts: 283
Joined: Fri Oct 23, 2009 11:19 pm

Return to Windows

Who is online

Users browsing this forum: No registered users and 1 guest


cron